人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

おそらくかなり初歩的な質問であるかもしれませんが、当方初心者/素人ですので、申し訳ございません。 Apache 1. 3. 29(win用) をインストールしたのですが、start を押すと the apache service is starting. という表示が出てから数秒後に、Failed to start the apache service. note the errors or messages and press the esc key to exit. という表示が出てしまいます。エラーログファイルは作成されていません。「My SQL入門以前」という本に付属のCD-ROMに収録されているApacheのバージョンをインストールしようとしています。実はインストールする前に、すでにインストールされていたApache 2.0.45をいったんアンインストールしました。また、Internet Explorerで http://localhost を表示させようとすると、「localhostは、このコンピュータとの接続をポート"world wide web サービス(HTTP)で確立するようにセットアップされていません。」とメッセージが出ました。 どうすれば、http://localhost を表示できるようになりますでしょうか。(OSはWindows Vista home premiumです。)

●質問者: makoto4649
●カテゴリ:コンピュータ インターネット
✍キーワード:2.0 Apache CD-ROM EXIT HOME
○ 状態 :終了
└ 回答数 : 3/3件

▽最新の回答へ

1 ● pahoo
●25ポイント ベストアンサー

まず、Administrator権限でApacheをインストールする必要があります。


それでも動かないようでしたら、Apache.exeに Windows XP SP2 互換モードを指定する必要があります。

Apache.exeを選択、右クリックして、互換性タブを選んでください。

◎質問者からの返答

ご指導ありがとうございます。いったんApacheをアンインストールし、コマンドプロンプトでAdministratorコマンドを入力しました。再起動し、Administratorでログインして Apacheをインストールしました。それでもApacheが動きませんでしたので、Apache.exeを右クリックして互換モードを選択しました。やはり同じメッセージ(Failed to start the Apache...)が出てきます。 他になにか原因が考えられますでしょうか。


2 ● pahoo
●35ポイント

1.3.29はかなり古い(2003年10月リリース)のですが、最新の「Apache 1.3.41 for Windows」をインストールすることは出来ませんか。

◎質問者からの返答

ありがとうございます。じつは「My SQL 入門以前」の著者が、できるかぎり最新版ではなく付属のCD-ROMからダウンロードするようにと指示しておりますため、古いものでトライしておりました。OSはwindows xp を想定して書かれているのですが、私のはvistaですし、やはり最新版をダウンロードするしかないのでしょうか。

最新版を試してみようと思います。ありがとうございます。


3 ● あひる
●30ポイント

Apacheの設定で、「Desktopとの対話を可能にする」設定にすると、起動時にDOS窓が開いて起動メッセージがズラズラと出るはずです。その中にエラーメッセージが見つけられるかと思います。

単なる想像ですが、Vista対応していないってことではないんでしょうかね?

◎質問者からの返答

最新版1.3.41をダウンロードしましたところ、起動いたしましたので、報告させていただきます。

pahoo様、ahirusan様 ご指導誠にありがとうございました!

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ