人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

Mac OSX(10.5.5)にimlib2-rubyをインストールしたいのですがうまくいきません。
どのようにしたらインストールできるか教えてください。

■やったこと
http://sourceforge.net/project/showfiles.php?group_id=2
からimlib2-srcをダウンロードし、
./configure
make
sudo make installでインストール。

http://pablotron.org/software/imlib2-ruby/
のDownload Imlib2-Ruby 0.5.2 (gem)よりgemをインストールし、
sudo gem install imlib2-ruby-0.5.2.gem

すると下記のようなメッセージが出ます。(はてなの文字数制限のため一部省略してます)
----
Building native extensions. This could take a while...
ERROR: Error installing imlib2-ruby-0.5.2.gem:
ERROR: Failed to build gem native extension.

/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby extconf.rb install imlib2-ruby-0.5.2.gem
checking for imlib_create_image() in -lImlib2... no
*** extconf.rb failed ***
Could not create Makefile due to some reason, probably lack of
necessary libraries and/or headers. Check the mkmf.log file for more
details. You may need configuration options.
〜〜
----

●質問者: studystudy
●カテゴリ:コンピュータ ウェブ制作
✍キーワード:.fr Download Extensions gem Mac OS
○ 状態 :終了
└ 回答数 : 2/2件

▽最新の回答へ

1 ● hoongt
●0ポイント

ダウンロードサイトに書いてないですか?

◎質問者からの返答

特に見つかりませんでした。どこに書いてあるかご存知でしたら教えていただけますか。


2 ● zzz_1980
●100ポイント ベストアンサー

gem を使わずに source からコンパイルしてみてはどうでしょう。

imlib2-ruby-0.5.2.tar.gz を引いてきて展開する。

ruby extconf.rb

make

make install

log からは imlib2-src のインストールまでは正常に出来ているように見えます。

◎質問者からの返答

試してみましたが

ruby extconf.rbの時点でgem installの時とほぼ同じメッセージがでてきてうまく行きません・・・

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ