人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

vistaですが、経理関連のソフトを業者に入れてもらおうとしたら
ドットネットが入っていないのでできないと言われました。
リカバリーしたばかりのパソコンなのですが、これは最初から入っているものなのでしょうか。

●質問者: tacoru
●カテゴリ:コンピュータ インターネット
✍キーワード:VISTA ソフト ドット ネット パソコン
○ 状態 :終了
└ 回答数 : 5/5件

▽最新の回答へ

1 ● かえる
●20ポイント

Vistaには.NET Framework 3.0が最初から入っています。

これでは以下のアプリケーションが動きます。

.NET 2.0 アプリケーション

.NET 3.0 アプリケーション

まずは、経理ソフトの.NETのバージョンを聞いてみてください。

以下のバージョンだと、新たにインストールする必要があります。

.NET 1.1 アプリケーション

.NET 3.5 アプリケーション

別バージョンの.NET Framework ダウンロードは以下から行えます。

http://msdn.microsoft.com/ja-jp/netframework/cc807036.aspx


参考:

http://itpro.nikkeibp.co.jp/article/COLUMN/20061017/250853/

http://fnya.cocolog-nifty.com/blog/2006/12/net20net30_197e.html

◎質問者からの返答

ありがとうございます。


2 ● legnum
●20ポイント

Vistaは.NET Framework3.0が標準装備になっています

.NET Framework 3.0 環境構築-実行環境の構築

http://msdn.microsoft.com/ja-jp/library/cc825663.aspx#action

入っていない理由はわかりませんが入れたら良いのではないでしょうか

http://www.microsoft.com/downloads/details.aspx?FamilyId=10CC340...

◎質問者からの返答

ありがとうございます。


3 ● くまっぷす
●20ポイント

http://www.atmarkit.co.jp/fwin2k/win2ktips/246checkvdnfw/checkvd...

Windows Vistaにはインストールしおわった状態で.NET 2.0と3.0がインストール済み。

もし他のバージョンが必要な場合はマイクロソフトから無料でダウンロードしてインストールすることができる。

Microsoft .NET Framework Version 1.1

http://www.microsoft.com/downloads/details.aspx?displaylang=ja&F...

Microsoft .NET Framework 3.5

http://www.microsoft.com/downloads/details.aspx?FamilyID=333325f...

業者の発言意図はちょっとわからないですが、下手に他のバージョンの.NETを入れて何か互換性問題が生じたら困る、と思ったのかもしれません。1.1対応のアプリだとすると、それはかなり古いので心配かも。

#それぞれ何かあったらアンインストール可能です。

◎質問者からの返答

ありがとうございます。


4 ● Lew
●20ポイント

OSやそのときのバージョン(SPいくつなのか)、またはメーカーによって入っていたり、入っていなかったりします。また、入っていてもバージョンが違うということもある(SPがいくつかある)なかなか厄介なものですが、Windowsのサイトからダウンロードできます。

http://msdn.microsoft.com/ja-jp/netframework/default.aspx

たまにソフトがどのバージョンの.Netを要求しているのかによって違ってきますがとりあえずは最新版をダウンロードしておけばよいのではないでしょうか。

ただ、思うのはその業者もドットネットくらいダウンロードして持ってきておいてほしいとは思いますよね、自分もソフトウェアの販売をしていたことがありますが、必要にありそうなツールはもっていってましたよ。

◎質問者からの返答

ありがとうございます。


5 ● うがや
●20ポイント

Vistaの場合、必ず.net frameworkのバージョン3.0が入っています。

通常ほとんどのソフトはこれで動きますが、まれに最新の.net framework 3.5 SP1 が入っていないと動かないソフトがあります。

.net framework 3.5 SP1を使用するソフトはまだ少ないので・・確立は低いと思いますが・・・。

ただ、何にせよ.net frameworkはインターネットにつながった環境では即座に無料でダウンロード・インストールが可能です。

どのバージョンを入れていいかわからない場合は、.net framework 3.5 SP1を入れておけば通常問題ありません。

.net framework 3.5 SP1 ダウンロードページ

◎質問者からの返答

ありがとうございます。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ