人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

php_mecab-0.3.0.tgzのコンパイルが通りません
http://d.hatena.ne.jp/rsky/20071228/1198841049
PHP5.2.9からPHP5.3.0へアップデート後の症状なので
PHP絡みで原因がありそうです.
原因やコンパイルを通す方法が分かりません,よろしくお願いします。

cc -I. -I/usr/local/src/php_mecab-0.3.0 -DPHP_ATOM_INC -I/usr/local/src/php_mecab-0.3.0/include -I/usr/local/src/php_mecab-0.3.0/main -I/usr/local/src/php_mecab-0.3.0 -I/usr/include/php -I/usr/include/php/main -I/usr/include/php/TSRM -I/usr/include/php/Zend -I/usr/include/php/ext -I/usr/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /usr/local/src/php_mecab-0.3.0/mecab.c -fPIC -DPIC -o .libs/mecab.o
/usr/local/src/php_mecab-0.3.0/mecab.c:335: error: duplicate 'static'

/usr/local/src/php_mecab-0.3.0/mecab.c: In function 'php_mecab_node_list_method':
/usr/local/src/php_mecab-0.3.0/mecab.c:1546: warning: 'php_set_error_handling' is deprecated (declared at /usr/include/php/main/php.h:293)

make: *** [mecab.lo] エラー 1

環境
centos5.2
PHP5.3.0
php_mecab-0.3.0
mecab 0.97


●質問者: hisugawa
●カテゴリ:インターネット ウェブ制作
✍キーワード:AT CC LIB LO Make:
○ 状態 :終了
└ 回答数 : 1/1件

▽最新の回答へ

1 ● chrono1742
●60ポイント

なぜphpizeを使わないのでしょうか?

(参考)http://www.saba-kan.net/blog/2009/04/php_mecab%E3%81%AE%E3%82%A4...

◎質問者からの返答

phpize使っていますが何か問題でも?

make clean

phpize

./configure --with-php-config=`which php-config` --with-mecab=`which mecab-config`

make

参考URLは5.3.0リリース前の情報ですので参考になりませんでした。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ