人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

PHPでSHA1ハッシュ化する必要があるのですが、
PHP Version 4.2.4 のため、ビルトインの sha1() は使えません。
PHPのバージョンを上げるという根本的な対策はとりあえず棚上げして、
外部モジュールなどの、代替手段はありますか?

●質問者: jetta_swingin
●カテゴリ:インターネット ウェブ制作
✍キーワード:PHP SHA1 はと ハッシュ バージョン
○ 状態 :終了
└ 回答数 : 1/1件

▽最新の回答へ

1 ● mattn
●60ポイント ベストアンサー

使った事はありませんが、pure phpによる実装はあるみたいですね。

http://www.phpclasses.org/browse/package/65.html

ライセンス等も確認する必要があるかもしれません。

◎質問者からの返答

ありがとうございます。

試してみます。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ