人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

Rails初心者です。
gemでgetttextをインストールし「environment.rb」をを書き換えた後サーバーを起動すると以下のエラー文がでました。
何が問題でどう対処すればよいのでしょうか?

/Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `gem_original_require': no such file to load -- gettext/rails (MissingSourceFile)
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/active_support/dependencies.rb:495:in `require'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/active_support/dependencies.rb:342:in `new_constants_in'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/active_support/dependencies.rb:495:in `require'
from /Users/***/Documents/workspace/memopad/config/environment.rb:62
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `gem_original_require'
from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:31:in `require'
from /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/gems/1.8/gems/activesupport-1.4.4/lib/active_support/dependencies.rb:495:in `require'
(残り文字数制限のため不掲載)

ruby 1.8.6
Rails 2.3.5
gettext 2.1.5


●質問者: o8o
●カテゴリ:コンピュータ ウェブ制作
✍キーワード:.fr ActiveSupport config gem gettext
○ 状態 :終了
└ 回答数 : 3/3件

▽最新の回答へ

1 ● snow_leopard
●20ポイント

railsのバージョンによって動作しないこともあるとか。

http://www.yotabanana.com/hiki/ja/ruby-gettext-howto-ror.html


2 ● azumi1975
●10ポイント

environment.rbの設定を見直してください


3 ● lunlumo
●50ポイント ベストアンサー

同じ現象に遭った事は無いのですが,検索した所環境変数GEM_HOMEを設定してなおったとの情報が引っ掛かりました。

http://www.gesource.jp/weblog/?p=427

因に,2.2から標準で国際化ライブラリが含まれているので,特に理由がないのであればそちらを使われた方が良いのではないかと。

http://guides.rubyonrails.org/i18n.html

◎質問者からの返答

指定のバージョンに合わせてたり環境変数GEM_HOMEを設定してみましたが駄目でした。

標準で国際化ライブラリを使用してみようと思います。

ありがとうございました。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ