人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

RHEL4 に yum で Java6 をインストールしたいのですが、なかなか上手くいきません。実行環境のみインストール出来ればいいので

sudo yum install jre-1.6.0-openjdk

と打っているのですが、

No Match for argument: jre-1.6.0-openjdk
Nothing to do

と言う結果になります。尚、yum を使ってだと j2re-1.4.2-11.2.el のインストールは出来ました。

下記が rpmforge.repo に記述されているリポジトリのミラーリストのURLです。
http://apt.sw.be/redhat/el4/en/mirrors-rpmforge

redhat-release で表示されているOSの名前は下記です。
Red Hat Enterprise Linux ES release 4 (Nahant Update 8)

どうすれば良いのか、ご教示いただければ大変ありがたく思います。

宜しくお願い致します。m(_ _)m

●質問者: jazzmine
●カテゴリ:コンピュータ
✍キーワード:E-1 EL Es JRE nothing
○ 状態 :終了
└ 回答数 : 2/3件

▽最新の回答へ

1 ● baron
●60ポイント ベストアンサー

RHELのリポジトリにはライセンスの問題があって収録されておりません。

Sunのサイトから直接ダウンロードしてください。

http://www.java.com/ja/download/linux_manual.jsp?locale=ja&host=...


インストールの手順はこちらです。

http://www.java.com/ja/download/help/5000010500.xml#rpm

◎質問者からの返答

ありがとうございます。助かりました!


2 ● Committeeman
●20ポイント

v5向けは用意されている

http://www.jp.redhat.com/support/errata/RHEA/RHEA-2008-0082J.htm...


v4向けのyumパッケージは用意されていない模様

下記からLinux用のRPMをダウンロードしてインストールするしかないと思われる

http://java.sun.com/javase/ja/6/download.html


余談だが v4 は Production 3 に入ったので、そろそろバージョンアップを視野に入れておいたほうがいいかもしれない

http://www.jp.redhat.com/security/updates/errata/

◎質問者からの返答

ありがとうございました。m(_ _)m

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ