人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

普段phpを使用しているプログラマーです。これからRailsの勉強をしたいと考えておりますが、Railsのバージョン(1.0系or2.0系)を何から始めるのがメジャーなのかと困っております。
普段Railsで開発されている方に回答頂けたら嬉しいです。

●質問者: camelmasa
●カテゴリ:コンピュータ ウェブ制作
✍キーワード:0系 2.0 PHP Rails バージョン
○ 状態 :終了
└ 回答数 : 4/4件

▽最新の回答へ

1 ● yamaneroom
●23ポイント

Ruby on Railsを使うならバージョン2.2以上を使おう。

◎質問者からの返答

回答有難う御座います!

なんか熱いコメントで。嬉しいです!


2 ● ニャンざぶろう
●23ポイント ベストアンサー

新しく学習するなら、やっぱり最新版の2.3.8でしょう。

Ruby on Railの本家

http://rubyonrails.org/

Get Started のバージョンも2.3.8ですしStableの位置づけですよ?。


3 ● cuspos
●22ポイント

2.3.8使ってください。

1系とでは内部的にも書き方的にも、いろいろ作法が異なります。

最近仕事の合間にプログラム初心者に教えながらWEBアプリ実装しましたが、初心者でも1ヶ月かからずざっくりとした実装ができるようになります。頑張ってくださいね。


4 ● basasitarou
●22ポイント

もうすぐ3も出ることですし、1のことはほっといて良いと思います。

3が出ることに備え、2.3系の安定版を勉強しておくことをお勧めします。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ