人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

Google App Engine をローカル環境で実行し、サーブレットにリクエストを発行するとエラーになります。

解決方法を教えて頂けないでしょうか。エラーの内容は以下のとおりです。

HTTP ERROR 500

Problem accessing /showdata. Reason:

javax.servlet.FilterChain is a restricted class. Please see the Google App Engine developer's guide for more details.
Caused by:

java.lang.NoClassDefFoundError: javax.servlet.FilterChain is a restricted class. Please see the Google App Engine developer's guide for more details.
at com.google.appengine.tools.development.agent.runtime.Runtime.reject(Runtime.java:51)
at com.google.apphosting.utils.servlet.TransactionCleanupFilter.doFilter(TransactionCleanupFilter.java:43)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157)
at com.google.appengine.tools.development.StaticFileFilter.doFilter(StaticFileFilter.java:122)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1157)
at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:388)

(文字数制限により途中省略)

at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:404)
at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:409)
at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:582)

●質問者: tyn
●カテゴリ:コンピュータ ウェブ制作
✍キーワード: Class AT ENGINE Google Google App Engine
○ 状態 :終了
└ 回答数 : 2/2件

▽最新の回答へ

1 ● tasklight
●50ポイント

「Google App Engine をローカル環境で実行」の意味がわからないのですが、自サーバにJavaサーブレット環境を構築して試行したということでしょうか。

だとすると、Google App Engine に必要なクラスが不足しており、質問のようなエラーが出ているのだと思います。


Google App Engine上で実行したときにもエラーは表示されますか?

◎質問者からの返答

説明不足失礼しました。

Google App Engine をローカル環境で実行 ⇒ Google App Engine をEclipseからローカルの開発環境で実行

Google App Engine のEclipseプラグインをインストールし、Eclipseからプロジェクトを作成しました。

サーブレット環境は自動的に構築されているようです。

作成直後のプロジェクトを実行する場合、クラスを追加する必要はないはずなのです。

ちなみに、Google App Engine上で実行したときには上記エラーは起きません。


2 ● akagi_paon
●100ポイント ベストアンサー

どうやら Google App Engine のバグみたいですね。

servlet-api.jar を Tomcat のものと置き換えると動いたなどの報告があるみたいです。

http://code.google.com/p/googleappengine/issues/detail?id=2324

SDK の問題かもしれませんので最新バージョンにしておくことをお勧めします。

◎質問者からの返答

バグだったのですね。ありがとうございました。

Pleiadesを3.4から3.5に変えたところ問題なく動きました。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ