人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

いまRubyのバージョン1.8.8をリリースするかどうかの議論がされています(http://redmine.ruby-lang.org/issues/show/4207)。
Rubyの最新の安定板は1.9.2ですので、古い1.8系列に新しいバージョンを出すべきなのか、出すのならどのような位置付けで、どのような機能を盛り込むべきなのか。
私はコア開発者ではありませんが、この議論の参考になればと思いアンケートをさせていただきます。
1.8.8についてのご意見をください。

●質問者: nuna
●カテゴリ:コンピュータ
✍キーワード:JRuby Rails Ruby あなた いただきます
○ 状態 :終了
└ 回答数 : 100/100件

Q01.あなたが主に使っているRubyのバージョンは何ですか?(CRuby限定で)
A. 1.8.6以下
6
A. 1.8.7
11
A. 1.8 trunk
4
A. 1.9.1
4
A. 1.9.2
12
A. 1.9 trunk
63

Q02.1.8.8をリリースしてほしいですか?
A. はい
15
A. いいえ
85

Q03.1.8.8に一番望むことはなんですか?
A. 1.9の機能をバックポート
4
A. 1.9への移行を支援する機能
2
A. バグ修正
2
A. 安定性の向上
76
A. (JRubyなど)他のRuby処理系との互換性向上
2
A. 長期間のサポート
3
A. 1.8.8は必要ない(Q2.で「いいえ」)
11

Q04.(1.9に移行していない方へ)移行しない理由はなんですか?
A. 使っているライブラリが1.9に対応していない
10
A. 使っているフレームワーク(Railsなど)が1.9に対応していない
4
A. 1.8で作成したプログラムが多く移行が大変
8
A. Encodingの仕組がよくわからない
8
A. 1.9はまだ十分に安定していない
3
A. 1.8で十分
77
A. 1.9の資料が少ない
5
A. 会社のルールで1.8を使うと決まっている
4
関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ