人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

現在MacOS 10.6.7の買ったばかりの状態からhttpd.confでPHPを有効にし、サイトのドキュメントルートを変えるだけの作業をしたところです。
これからPEARをインストールしたいのですが、すでに動いているPHPのバージョン(5.3.4)が新しくてgo-pear.phpも使えないようです。
どのようにしてPEARをインストールすればよいでしょうか。
なお、MacPortsやXAMPP等は使うつもりりません。

●質問者: wackey
●カテゴリ:コンピュータ ウェブ制作
✍キーワード:Go httpd MacOS MacPorts Pear
○ 状態 :終了
└ 回答数 : 3/3件

▽最新の回答へ

1 ● あすか
●27ポイント

go-pear.phpの代わりに "http://pear.php.net/go-pear.phar" を使って下さい。

実行時は以下の通り。

php -d detect_unicode=0 go-pear.phar
◎質問者からの返答

Could not open input file: go-pear.pharと言われてしまいます。


2 ● online_p
●13ポイント

http://voqn.blogspot.com/2011/04/phpunit-phing-macosx-php.html

◎質問者からの返答

ありがとうございます。今のところPHPを入れ直すことは考えていません。


3 ● あすか
●40ポイント ベストアンサー

Could not open input file: go-pear.pharと言われてしまいます。

"http://pear.php.net/go-pear.phar" をダウンロードしましたか?

◎質問者からの返答

すいません。ダウンロードして、サイド実行してみたのですが、

Sorry! Your PHP version is too new (5.3.4) for this go-pear.

Instead use http://pear.php.net/go-pear.phar for a more stable and current

version of go-pear, more suited to your PHP version.

と言われてしまいます。ダウンロードの仕方が悪いのでしょうか?

20:00加筆:

できました。普通にhttpでダウンロードしてきたものをコマンドでたたいたら、PEARの画面になりました。ありがとうございます。

あとはパスの設定等が残っています。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ