人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

iOS用のAppStoreにある条件※(動作機種)の項目は、どのように決定されているのでしょうか?
たしかiTunesConnectで登録する際に設定項目は無かったと記憶していますが、アップル側のテストで自動的に決まるものなのか、あるいは開発者側が何処かで設定するものなのか、情報がありましたら、よろしくお願いします。

※例:「条件: iPhone 3GS、iPhone 4、iPod touch(第3世代)、iPod touch (第4世代) および iPad 互換 iOS *.* 以降が必要」

●質問者: kuni
●カテゴリ:コンピュータ インターネット
✍キーワード:iOS iPad iPhone 3GS iPhone 4 iPod touch
○ 状態 :終了
└ 回答数 : 2/2件

▽最新の回答へ

1 ● km1981
●500ポイント ベストアンサー

.plist ファイルに書いてあります

http://stackoverflow.com/questions/1377478/how-does-itunes-connect-detect-my-apps-minimum-os-requirements

◎質問者からの返答

すいません説明不足でした。

聞きたいのは、OpenGL ES 2.0の利用など、OSのバージョンとは違う理由でiPhone3GS以降用にしたい場合についてです。

iPhone3Gで3GS以降用のアプリをダウンロードしようとした場合にGLES2.0に未対応云々と出る場合もあるので、OSバージョンだけで判断はしていないと思います。


2 ● online_p
●50ポイント

環境変数を見ているのではありませんか。

http://www.cybersyndrome.net/evc.html

◎質問者からの返答

Mac本体に関連した情報では無いため、違うと思うのですが…。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ