人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

Rubyの環境を構築しようと思い、こちらのサイト(http://d.hatena.ne.jp/seiunsky/20081228/1230485404)を参考に手順を進めているのですが、
C:\rails_test>rails -d mysql sample
のところで、
序数 3873 がダイナミックライブラリ libeay32.dll から見つかりませんでした。
といったエラーが出てしまいます。libeay32.dllのバージョンかと思い、様々なバージョンのlibeay32.dllをダウンロードして、Ruby\binに置いていって試しているのですが、序数**の部分の数字が変わっていくだけでエラーが解消されません。
どのバージョンかのlibeay32.dllかがアタリと考え、色々なバージョンを試していくしかないでしょうか?
RubyとRailsのバージョンは以下です。よろしくお願いします。

ruby 1.9.2p136 (2010-12-25 revision 30365) [i386-mswin32]
Rails 3.0.9

●質問者: koime_ryokutya
●カテゴリ:コンピュータ インターネット
✍キーワード:2010-12-25 DLL i386 MySQL Rails
○ 状態 :終了
└ 回答数 : 2/2件

▽最新の回答へ

1 ● km1981
●50ポイント

Railsのバージョンが間違っていると思います

いまRuby 1.9.2に対応している安定バージョンは3.0.7です

http://rubyonrails.org/


2 ● a-kuma3
●50ポイント

openssl 周りのライブラリがあってないんでしょうね。

openssl のライブラリを変えるときには、ひとつのバージョンで、libeay32.dll ssleay32.dll の二つを合わせてコピーしなきゃいけないんだと思います。

http://d.hatena.ne.jp/fishergreen/20101229/1293603157


openssl のバージョンは、0.9.8 でいけそうですよ。

関連質問


●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ