人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

Railsに関する質問です。
下記の手順を踏んだところ、6番のようなエラーが発生しました。
具体的な解決方法をご教授下さい。
下記はバージョン情報です。
Ruby:1.8.7
Rails:2.3.8
OS:mac os x 10.6.8
コメント欄にgem listを付記します。ご参照下さい。

1.activerecord-salesforce-adapterをインストール
$ gem install activerecord-activesalesforce-adapter

2.rails testでtestアプリケーションを作成
$ rails test

3.ruby /script/serverで既読を確認
$cd test
$ruby script/server

4./config/enviroment.rbを下記のように編集
Rails::Initializer.run do |config|
config.time_zone = 'UTC'
require 'activesalesforce'
end

5./config/database.ymlを下記のように編集
development:
adapter: activesalesforce
url: https://www.salesforce.com
username: <実際のユーザーアカウントを入力>
password: <実際のパスワードを入力>

6.3同様にサーバーを起動すると、エラーが発生
$ ruby script/server
`gem_original_require': no such file to load -- activesalesforce (MissingSourceFile)
詳細なエラーはコメント欄に記載しました。

最後まで読んで頂き、ありがとうございます。
人力検索とtwitterを通じたプログラミングの先生も合わせて募集しております。
興味のある方は、コメント欄で詳細をご確認下さい。

●質問者: ぷりっぷりのおしり
●カテゴリ:ウェブ制作
○ 状態 :終了
└ 回答数 : 3/3件

▽最新の回答へ

1 ● エユ
●0ポイント

ふたを閉めて開けるとなおっていることがあります。


2 ● ペッタン
●0ポイント

上の人の様にふたを閉めたり、

再起動したら直る事がありますよ!


3 ● takano32
●300ポイント ベストアンサー

まとめ

1. gem install bundler でGemfilesとかあるディレクトリで bundle install

2. よしなに bundler がいろいろいれてくれる

3. bundler環境下で実行

$ bundle exec ruby script/server

◎質問者からの返答

回答ありがとうございました。

詳細はコメント欄を参照してください。

関連質問

●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ