人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

WordPressの自動更新エラーについて教えてください。

WordPress 2.7.1から、WordPress 3.3.1 にブラウザ上で
アップデートしようと試みたのですが、以下のようなエラーが出てしまい更新することができません。
エラーは出るのですが、その後も古いバージョンで普通に動いている状態です。

syntax error, unexpected $end in /home/joetran1/public_html/yayoirestaurant.com/wp-admin/includes/class-pclzip.php on line 1688

このような現状で、3.3.1に更新するには、どのような方法がありますでしょうか?
できれば、バックアップを取って、再インストールする方法は避けたいと思います。

参考の為、上記エラーに出てくる、class-pclzip.php のコードを以下にアップしてあります。
一応パスワードをかけてます。パスワードは hatena です。
http://www.obanzaiya.com/japanesefood/20120118211535.html

どうぞよろしくお願いします。

●質問者: Tomo
●カテゴリ:ウェブ制作
○ 状態 :終了
└ 回答数 : 1/1件

▽最新の回答へ

1 ● oil999
●100ポイント ベストアンサー

>参考の為、上記エラーに出てくる、class-pclzip.php のコードを以下にアップしてあります。
そのファイルを見ましたが、途中で(1835行目で)切れてしまっています。
class-pclzip.phpが破損しているのではないでしょうか。
ご確認ください。

WordPress 2.7.1からclass-pclzip.phpのみ抽出してアップロードするか、
http://www.phpconcept.net/pclzip/pclzip-downloads
からRelease 2.5をダウンロードして差し替えてみてください。


Tomoさんのコメント
無事更新できました。 ありがとうございました。
関連質問

●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ