人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

rubyでjsonを使おうとするとエラーがでます。
rubyのバージョンは1.8.7です。jsonをrequireして動かそうとすると
uninitialized constant JSON (NameError)
のようなエラーがでてしまいます。色々調べてみても原因がよくわかりませんでした。
よろしければ、アドバイスお願いします。


●質問者: osietekudasaibadr
●カテゴリ:ウェブ制作
○ 状態 :終了
└ 回答数 : 1/1件

▽最新の回答へ

1 ● うぃんど
ベストアンサー

JSONを扱うライブラリをインストールしていない。あるいは、失敗しているのでは?

環境によって対応は違いますが gem install json とかやりました?


話は変わりますが、
1.8系は2013年6月より先、ノンサポートになりますので、
学習を続けるのであれば、早い段階で1.9系に乗り換えましょう。
http://www.ruby-lang.org/ja/news/2011/10/07/plans-for-1-8-7/
もちろん、
先月リリースされたばかりの2.0系にチャレンジしてもOKですが、
サンプルも相談相手も揃うまでにしばらく時間がかかります。
http://www.ruby-lang.org/ja/news/2013/02/24/ruby-2-0-0-p0-is-released/


osietekudasaibadrさんのコメント
そうなんですね。1.8.7で作成したものが多く、なかなか1.9の方に切換えれなくて・・・ jsonですが、requireをjson/pureにしたらなんとかなりました。 ありがとうございます。
関連質問

●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ