人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

さくらインターネットのビジネスプロのサーバーで、paypal決済を導入したのですが、SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failureというエラーが出てしまいます。
解決方法はありませんでしょうか?


●質問者: makocan
●カテゴリ:ウェブ制作
○ 状態 :終了
└ 回答数 : 1/1件

▽最新の回答へ

1 ● dilutionist
●200ポイント

POODLE脆弱性対応のためにPayPalもSSLv3のサポートを中止したためと思われます。
PayPal Response to SSL 3.0 Vulnerability (aka POOD... -

CURLOPT_SSLVERSION を TLSv1 に変更するなどの対応を試してみて下さい。

curl_setopt($ch, CURLOPT_SSLVERSION, CURL_SSLVERSION_TLSv1);

PayPal IPN acknowledgements failing with SSL routines:SSL3_READ_BYTES:sslv3 alert handshake failure - Stack Overflow

------

訂正です。こちらの方がエラーメッセージに合致する対策のようです。PPHttpConfig.php に、

CURLOPT_SSL_CIPHER_LIST => 'TLSv1'

を追加してみて下さい。

php - SSL error can not change to TLS - Stack Overflow


makocanさんのコメント
うーん。これではダメでした。 他になにか対策方法有りますでしょうか?

dilutionistさんのコメント
別の対応方法を追記しましたので、試してみて下さい。
関連質問

●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ