人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

composerを使ってabraham/twitteroauthのインストールができません。
環境は、
Windows8.0
PHP 5.6

c:\php\php.ini,exe,他PHP他一式
composerをここにインストール

composer自体はインストールできたようです
"コマンドプロンプトを起動して「composer」と打って確認しましょう"
と同じ画面が出てきます。
http://qiita.com/mikoski01/items/266469535e860312145d

c:\php\composer.json ->右クリック -> Use compose here
->php composer.phar require abraham/twitteroauth
*補足のメッセージが出てきてしまいます。

composer.pharは、c:\ProgramData\composerSetup\bin
にあったものをc:\phpコピーしています。

composer.jsonは以下の通りです。
"require": {
"php": ">=5.6.2",
"abraham/twitteroauth": "0.5.0"
}
参照先:http://yfroot425.hatenablog.com/entry/2015/02/12/235758


●質問者: kohhi
●カテゴリ:インターネット ウェブ制作
○ 状態 :終了
└ 回答数 : 1/1件

▽最新の回答へ

質問者から

以下が、C:\php>php composer.phar require abraham/twitteroauth と入力したときのメッセージです。よろしくお願いします。

C:\php>php composer.phar require abraham/twitteroauth


[Seld\JsonLint\ParsingException]
"./composer.json" does not contain valid JSON
Parse error on line 1:
“ph
^
Expected one of: 'STRING', 'NUMBER', 'NULL', 'TRUE', 'FALSE', '{', '['


require [--dev] [--prefer-source] [--prefer-dist] [--no-plugins] [--no-progress]
[--no-update] [--update-no-dev] [--update-with-dependencies] [--ignore-platform

] [--] [<packages>]...


1 ● braahmaNa
●300ポイント ベストアンサー

json形式になってないんじゃないですか、コレ?
下記の様に{}で囲んだら走りません?

{
"require": {
"php": ">=5.6.2",
"abraham/twitteroauth": "0.5.0"
}
}


kohhiさんのコメント
あっさりできました。回答ありがとうございました。

braahmaNaさんのコメント
何かエラーメッセージとか他の人の情報みたら{}無しでも行ける気はするんですけどね… まあ、手っ取り早くって事でw

kohhiさんのコメント
「何かレベル低いかもしれないな・・。」とはチョロット思いましたが、自分ではそれなりに考えた大問題でした。 Twitterログインを作ろうとしています。また、よろしくお願いします。

braahmaNaさんのコメント
地味に間違えてるモンほど自分では分かりにくいですし、仕方無いんじゃないっすかね?? もしアドバイス的なモノをさせて頂くとすれば、エラーメッセージきっちりと読む事かな?とかは思いますが… 今回のだと「有効なJSONが含まれていません」て書いてあるので(>_<)
関連質問

●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ