人力検索はてな
モバイル版を表示しています。PC版はこちら
i-mobile

プログラミングの変数命名に関する質問です。
すっごくどうでもいい話なので、お気楽にご意見頂ければと。

現在作成中のプログラムで、「TD誤差の自乗平均」を保存する変数が有ります。
素直に命名すると、TD誤差="TdError"で自乗平均(のルート)="Rmse"になります。

んで、上記変数名を"tdErrorRmse"にしようと考えたんですが、これって"Error"と"e"で同じ意味がかぶっててちょっと気持ち悪いです。

かと言って、"rmsTdError"にすると、"Rmse"という一般的な名称とはかけ離れて、これもイマイチ。

という訳で、何か良い名称が有れば教えて下さい。

●質問者: 森岡@GA将!!!!!!!!!
●カテゴリ:コンピュータ
○ 状態 :終了
└ 回答数 : 1/1件

▽最新の回答へ

1 ● avocado_knight
ベストアンサー

rmse_td (or rmseTd)


森岡@GA将!!!!!!!!!さんのコメント
う?ん、シンプルなのは良いんですが、「TD誤差」と言う単語が消えちゃってるのが気になります。 引き続き、他の方の回答もお待ちしています。

質問者から

変数名と、その名称にした根拠を併記して頂けると助かります。


関連質問

●質問をもっと探す●



0.人力検索はてなトップ
8.このページを友達に紹介
9.このページの先頭へ
対応機種一覧
お問い合わせ
ヘルプ/お知らせ
ログイン
無料ユーザー登録
はてなトップ