Flash のプラグインがないと、swfって表示させることができませんが、このプラグインは最近のブラウザ(IE,Netscape)に標準で入っていますか?もし入っているのなら、いつ頃のバージョンから入るようになったのかも合わせて教えてください。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2004/06/18 14:54:04
  • 終了:--

回答(6件)

id:aska1210 No.1

aska1210回答回数13ベストアンサー獲得回数02004/06/18 15:05:35

ポイント15pt

マクロメディアのページです。

基本的にははいっているみたいです。

いつ頃からはいっているかは分かりません。

申し訳ないです。

id:emmet

ありがとうございます。

やはり入ってるんですね〜。

※この後の回答には、いつからか、が判るサイトをぜひご紹介ください。

2004/06/18 15:08:29
id:hinetk No.2

hinetk回答回数516ベストアンサー獲得回数362004/06/18 15:35:07

ポイント15pt

>Shockwaveには for FreeHand や for Authorware など色々な種類がありますが、一般的には for Director、もしくはその後継ソフトのフォーマット for Flash を表す場合が多いようです。 とくに最新型の for Flash はデータ容量が小さくて済む為、最近は事実上ウェブで Shockwaveと云えば、これを指します。 Netscape Navigator(製品版)、Internet Explorerとも、3.0以降のバージョンであれば標準で組み込まれています。

とありますのでこの辺りからでしょう。

結構古いですね

id:emmet

ありがとうございます

こんなに古くからとは、知りませんでした。

プラグインがない人はこちらから…というのを今でも見かけるので、まだ標準じゃないマシンもたくさんあるのではと思ったのです。

2004/06/18 15:38:17
id:Yuny No.3

ねがい かなみ回答回数953ベストアンサー獲得回数132004/06/18 16:10:52

ポイント15pt

96年の年末にFlash1.0が出ています。

http://tohoho.wakusei.ne.jp/wwwxx018.htm

そのファイルは現在ありません

当時はNetscape Navigator 3.0、Internet Explorer 3.0。

http://pc.watch.impress.co.jp/docs/article/970123/mm.htm

マクロメディア、FreeHand 7J、Macromedia Flashを発売

Flash 1.0のニュースリリースです。この文面の様子から考えて、まだだったみたいですね。

Flashのリリース史。

とりあえず、調べられたのはここまでです。古いIEやNCのインストーラを調べれば、もしかしたら分かるかもしれませんが。

id:emmet

ありがとうございます。

印象としては、わりと最近までプラグインはプレインストールされてなかったような「気がする」んですね。←ホントに印象だけの話なのですが。

最初に回答くださったaska1210さんの紹介くださったコンテンツを見ても、XPなら標準でプレインストールされていると書かれている…ということは、Meや2000のころのWindowsマシンの頃のIE(ちょっと表現がおかしいですが)ではまだプラグインを入れる必要があったように見えますし…。

****

ただいま午後5時過ぎなのですが、この後夜中までアクセスできません。回答は帰宅次第拝見致します。

2004/06/18 17:06:43
id:aki73ix No.4

aki73ix回答回数5224ベストアンサー獲得回数272004/06/18 18:42:09

ポイント15pt

ちょっと質問の趣旨から外れるのかもしれませんが、emmetさんの回答のコメントを見ていて思ったので、書かせていただきます

swf(ShockWaveFile)には色々な動きや効果が拡張されるごとにバージョンアップしています

つまり、バージョンが上のフラッシュメーカーで作成されたフラッシュは、バージョンが低いプラグインが入っていても見ることができないのです

ですから、見れない人は『プラグインを入れてください』という表記になるわけです

だから、Flash3で作成されたswfならNetscape 4.8で見れても、最近のフラッシュは殆ど見れないのでPluginが必要といった状況になります

ブラウザごとにプレインストールされている細かいバージョンについてはちょっと資料が無いみたいです。勿論、手作業で調べることもできなくは無いですが・・・(^^;

ですから、XPや2003やMacOSXにFlashのプラグインがプレインストールされているからといって、インストールが不要なわけではなく、新しいバージョンのフラッシュメーカーで作成されたデータが出現すれば、バージョンアップのために上書きインストールする必要があります

id:emmet

ありがとうございます。

確かにそうですね、バージョンアップの問題がありますね。

企業で各個人に渡されているマシンですと、ソフトのインストールの制限をしているものが多いので、swfを使えるかどうか、が疑問だったのです。

んー、敷居がたかそうな気がしてきました。

ただインストールされていればいいというものではありませんね。。。

2004/06/18 23:42:41
id:KIROW No.5

KIROW回答回数38ベストアンサー獲得回数02004/06/18 19:28:06

ポイント15pt

WEBデザインの仕事をしてるものですが

フラッシュのショックウェーブプラグインは Windows98からOSに標準で同梱されましたね

おかげでこれからは気にせずフラッシュコンテンツが作れるとクライアントにプッシュした記憶があります

フラッシュプレイヤーの当時のバージョンは3か4くらいだったと思いますが はっきり覚えていません(すいません)

id:emmet

ありがとうございます。

古いバージョンのswfファイルに書き出すことが出来れば、大丈夫なのかしら〜と思いますが、なかなか一筋縄ではいかないですねぇ。。。

2004/06/18 23:45:18
id:kn1967 No.6

kn1967回答回数2915ベストアンサー獲得回数3012004/06/18 20:30:41

ポイント15pt

古いプレイヤーでは最新の機能を含んだものは再生できないので、ダウンロードページへのリンクを書いておくのが通例となっています。

id:emmet

ありがとうございます。

ここはひとつ、古いバージョンのswfファイルを作ってみて確認してみるのが良さそうですね。

-------------------------------------

みなさん、回答ありがとうございました。

古いバージョンのswfが、新しいバージョンでは動かないとか、そういうこともおきそうですけれども、なんとか試してみようと思います。

2004/06/18 23:49:34

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません