Promise社のRAIDカード、FastTrak SX4000 liteを使用して、HDD4台でRAID5を構成しています。

このドライブを共有にして、別のPCからアクセスすると、一番上の階層にあるファイルやフォルダは見えるのですが、ファイルにアクセスしてもエラーになり、フォルダの中にも入れません。
ちなみに、アクセス出来ないのはLAN上の別のPCからだけで、ローカルPCからはアクセス可能です。
解決方法を教えて下さい。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2004/09/19 03:29:56
  • 終了:--

回答(4件)

id:aki73ix No.1

aki73ix回答回数5224ベストアンサー獲得回数272004/09/19 03:38:57

ポイント20pt

ファイル共有は135,137-139などのポートを使うのですが

BlasterWormがはやったときにルーターなどの設定で外部から

UDP 135

TCP 135

UDP 137

UDP 138

TCP 139

にアクセスがあった場合は遮断してしまいアクセスできないような設定になっている場合があります

ルータの設定の可能性・FireWallソフトの遮断規則などでこれらのポートを確認してみてください

ローカルからアクセスができるということなので、ルータで透過させるかフィルタの設定があると思います

http://sonobe.s5.xrea.com/knowhow/computer/closeport.html

ポートを遮断しMSブラスト等のワームを防ぐ術

参考・・・この設定をすると同じような症状になります

id:tamulin

Norton Internet Security 2004を使用していますが、ファイヤーウォール機能は現在オフにしてます。

ルータは、NTT-MEのBA8000Proで、マニュアルを読むと、「WAN側からLAN側にかけてTCP/UDP 135-139番を塞いでおります。これらのポート番号のデータを透過させることは出来ません」とありますが、LAN内同士の話なので、関係ないのではないかと思うのですがどうなんでしょう?

2004/09/19 04:36:55
id:yasukana No.2

yasukana回答回数116ベストアンサー獲得回数02004/09/19 04:10:34

ポイント20pt

http://www.atmarkit.co.jp/fwin2k/special/winxp_over/winxp_over_1...

特集:Windows XPとは何か? 13.ファイルのセキュリティ設定

すみません。詳しい状況がわからないので、予想になってしまいますが、

おそらく、RAID構成が原因というよりもアクセス権限の問題だと思われます。

つまり、OSがWindowsNT系だとして話しますと、共有フォルダの

「共有」タブには相手方へのアクセスを許可してあっても、

「セキュリティ」タブに相手方へのアクセスを禁止していれば

結局フォルダも開けませんし、書き込みも出来ません。

閲覧時のユーザーアカウントと、接続許可ユーザー(共有とセキュリティの両方)を

再度確認してみてください。

id:tamulin

RAID構成にしているサーバのOSは、WindowsXP Professionalです。

接続しているクライアントのOSは、WindowsXP Home Edition、及び、Windows 2000 Professionalです。

質問のような現象になるのは、RAID構成にしているドライブのみで、同じマシンにRAID構成にしていないドライブもあるのですが、そちらの共有は全く問題なく読み書き出来ています。

セキュリティ設定うんぬんに関しては、イマイチよく理解出来てませんが、うまく共有出来ているドライブと、共有出来てないRAID構成のドライブでの設定は全く同じでした。

2004/09/19 11:13:00
id:ken_na8c No.3

ken_na8c回答回数26ベストアンサー獲得回数02004/09/19 10:17:41

ポイント20pt

URLはダミーです。

OSはWindows XP、2000のどちらでしょうか。

NTFSでディスクがフォーマットされていると推測

していますが、

共有時のセキュリティ設定と、そもそものディレクトリのセキュリティ設定が正しくなっているかどうか確認してみてください。

また、WindowsXPを利用している場合は、デフォルトですとファイル共有が簡易モードになっているので、フォルダオプションの設定から、簡易モードを解除し、

同様にセキュリティ設定を詳細に確認してみてください。

id:tamulin

何かいろいろいじってたら直っちゃいました。

やはりRAIDは関係なく、セキュリティ設定だったようです。

ありがとうございました。

2004/09/19 11:13:57
id:teshi No.4

teshi回答回数25ベストアンサー獲得回数02004/09/19 10:24:54

ポイント20pt

http://www.isonavi.com/onlinemanu/install/detail-016.html

フォルダのセキュリティ設定

共有フォルダへのアクセス権が読み取り専用になっていると思います。

どこからでも見えて問題なければ、Everyoneををフルアクセスで追加してあげれば、解消すると思います。

id:tamulin

何かいろいろいじってたら直っちゃいました。

やはりRAIDは関係なく、セキュリティ設定だったようです。

ありがとうございました。

2004/09/19 11:15:01

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません