FedoraCore4にwvWareをインストールしたいのですが、./configureをすると下記エラーで止まってしまいます。初心者で対処方法が分からず、困り果てています。


どなたか対象方法を教えて下さい。よろしくお願いします。

checking for libgsf-1... Package libgsf-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgsf-1.pcG
to the PKG_CONFIG_PATH environment variable
No package Glibgsf-1G found
configure: error:

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2006/03/11 14:46:00
  • 終了:--

回答(2件)

id:ttamo No.1

たも回答回数175ベストアンサー獲得回数292006/03/11 17:28:44

ポイント10pt

yum install libgsf-devel


あと、もしかしたら pkgconfig も入っていないかもしれないので


yum install pkgconfig


ですかね。

id:eno2i

どうもありがとうございます。試してみましたが、同じエラーが出てしまいます。wv-1.2.0.tar.gzというのをダウンロードしてインストールしようとしています。

2006/03/11 20:43:23
id:ttamo No.2

たも回答回数175ベストアンサー獲得回数292006/03/12 15:25:19

ポイント170pt

うーむ、それではちょっと面倒ですねえ。

Fedora 環境が手元にないので、具体的なアドバイスは難しいです。


/usr/lib/pkgconfig とか /usr/share/pkgconfig を調べて

libgsf-1.pc があるかどうか確認したり、

export PKG_CONFIG_PATH=/usr/lib/pkgconfig

とか

./configure --prefix=/usr とするだけで直ればいいのですが、


もう面倒なので、


この 1.0.3 あたりを入れてしまうか、

ここのをムリヤリ入れるか、

ここから SRPM を持ってきて、

rpmbuild --rebuild wv-1.2.0-3.src.rpm

rpm -Uvh /usr/src/redhat/RPMS/i386/wv-1.2.0-3.i386.rpm

のような感じにしたほうがいいかもしれません。

id:eno2i

export PKG_CONFIG_PATH=/usr/lib/pkgconfigの後に、./configureしたらできました!本当にどうもありがとうございます。助かりました。

2006/03/12 23:05:26

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません