QEMUを使用している人間なのですが、あるプログラムを、このエミュレータで確認しようとしたら、

Boot from Floppy0 failed
FATAL: Not a bootable disk

と表示されてしまいます。
FloppyがUSB接続の物のためでしょうか…。

回答の条件
  • 1人50回まで
  • 登録:2006/03/13 21:32:18
  • 終了:2006/03/19 13:20:05

回答(3件)

id:suenaga3 No.1

suenaga3回答回数19ベストアンサー獲得回数52006/03/14 22:55:01

ポイント27pt

まず、ホストOSが何なのか(OS名、バージョン)分かった方が解決

しやすいかと思います。

また、この説明だけだと状況がいまいち掴みにくいので、どの段階で

エラーが出たのか教えていただけるとありがたいです。

仮想OS上でプログラムを実行する際に出たエラーでしょうか?

そうであれば仮想OSの名前とバージョンも教えてください。

QEMUをフロッピー起動しようとしてエラーが表示されたのなら、

次のページがヒントになるかもしれません。

http://www.h7.dion.ne.jp/~qemu-win/HowToFloppyCdrom-ja.html

id:makocan

ご回答ありがとうございました。

>まず、ホストOSが何なのか(OS名、バージョン)

>分かった方が解決しやすいかと思います。

OSはWindowsXP Proffsional SP2を使用しております。

とりあえず、私が行った順にご説明いたします。

内容としては、PC起動時に、一番初めにブートされるフロッピーから、hellowWorldを表示させるという単純なプログラムが起動するといった物を制作しておりまして、今、行いたいのが、それをWindows上でエミュレータで表示したいというものです。

※エミュレーターで起動時は、HDに置いてあります。

そうすると、前述した様に、不思議なエラーが出てしまいます。

追記いたしますと、始めの段階では、同一プログラムで問題なくエミュレータが起動いたしました。

2006/03/15 00:23:38
id:suenaga3 No.2

suenaga3回答回数19ベストアンサー獲得回数52006/03/15 02:36:35

ポイント27pt

申し訳ありません。もう少しだけ状況の説明が欲しいです。

2度目の回答も質問に使わせてください。

-------------------------------------------

環境

 ホストOS: WindowsXP Pro SP2

 仮想OS : WindowsXP Pro SP2

目的

 仮想OSの起動をフロッピーブートで行う。

-------------------------------------------

3つほど質問があるのですが答えていただけますか?

 

1) 何が置いてあるかわかりません。

> ※エミュレーターで起動時は、HDに置いてあります。

 HDに置いてあるものとは何でしょう。

 フロッピーイメージでしょうか?

 

2) 成功した状況がよくわかりません。

> 始めの段階では、、、

 どの段階で問題なく起動したのでしょうか?

 

3) 失敗した状況がわからなくなりました。

 たとえば前述のURLに倣って、、、

  コマンドプロンプト上で

  > qemu.exe -L .\pc-bios -fda \\.\a: -boot a

  実行時にエラーダイアログが表示された。

 というような回答だと、とてもありがたいです。

 

よろしくお願いします。

id:makocan

口下手なため、お手数をおかけして、申し訳ございません。

実は、ある本を参考にし、試しているだけなので、QEMUがいかなるものなのか、理解していないのかもしれません。。。

説明が下手なため、QEMU実行時の画像とソースをアップロード致しました。

宜しければ、ご確認頂けますと幸いです。

■QEMUを実行した画像

http://www.geocities.jp/again5651/image1.gif

■実行しようとしているフロッピーイメージ

http://www.geocities.jp/again5651/first.zip

2006/03/15 03:13:14
id:i_kumagoro No.3

i_kumagoro回答回数170ベストアンサー獲得回数582006/03/16 13:31:49

ポイント26pt

アップロードされたイメージを確認しましたが、

こちらにあるQEMU 0.8.0のバイナリでは問題なく動作しました。

あなたが示した画面の上部のコンソールが起動時に入力したパラメータだとすれば、アップロードされたイメージとあなたが使用されているfdimage0.binというファイルが実際には異なった内容のものである可能性があると思います。

(dreams.imgがそもそもおかしいとかmakeが見えないところで悪さをしているとか)

あなたが使用しているイメージファイルが本当に正しいものかどうか確認して下さい。

id:makocan

そうですか。。。

ちょっと、自分で試してみようと思います。

ありがとうございました。

2006/03/19 13:19:46

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません