CentOS4.5にyumを使いPHPの5をインストールしました。


この場合なのですが、自分はPHPをmod_phpで動かしたいのですが、何も設定変更する必要はないのでしょうか?

また、この場合PHP5とPHP4はどちらが優先でうごくのでしょうか?
自分はPHP5のモジュールバージョンで動かしたいのですが確認方法ややり方がわかりません。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2007/09/18 04:54:06
  • 終了:2007/09/25 04:55:45

回答(4件)

id:KUROX No.1

KUROX回答回数3542ベストアンサー獲得回数1402007/09/18 05:34:00

ポイント23pt

http://jp.php.net/phpinfo

現状は、phpinfo()を実行すれば、そのモジュールはどっちを

つかって実行されているかは分かる。

id:keino No.2

keino回答回数204ベストアンサー獲得回数112007/09/18 06:28:44

ポイント23pt

httpd.confを書き換えれば、起動するPHPのバージョンを切り替えることができます。

以下のURLは、OSが違いますがやる作業は全く同じです。

http://mitc.xrea.jp/diary/040

http://moon.dw.land.to/ppblog/index.php?UID=1186314031

id:Yota No.3

Yota回答回数453ベストアンサー獲得回数282007/09/18 09:15:28

ポイント22pt

http://www.php.net/manual/ja/install.unix.apache2.php

Apache 2.0.xのモジュールとして動かすのなら、httpd.confにこんなことが書いてあればいいでしょう。

LoadModule php5_module modules/libphp5.so

AddType application/x-httpd-php .php

PHP4については、どうやってインストールしたか書かれてないのでわかりかねます。

id:poshu

PHP4については、デフォルトでApacheと供にインストールされていました。

ご指摘のないようで確認したのですが、

記述はありませんでした・・・

記述がないということはCGIモードで動いているということでしょうか?

CentOSのデフォルト状態なのでおかしなことはしていないと思うのですが・・・

2007/09/18 09:22:06
id:Yota No.4

Yota回答回数453ベストアンサー獲得回数282007/09/18 09:33:42

ポイント22pt

/modules/libphp5.so

/cgi-bin/php

こんなファイルがどこかにないか探してみたらどうでしょう。

http://www.php.net/manual/ja/security.cgi-bin.php

なければ、いったんPHP4をremoveして、PHP5をinstallし直すとか。

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません