RHLES4にてperlをv5.8.5→v5.8.8にバージョンアップしたいのですが

一番スマートな方法を教えてください
依存関係を注意する必要はあるのでしょうか?
$ rpm -qa | grep perl
perl-5.8.5-24.RHEL4
perl-URI-1.30-4
perl-libwww-perl-5.79-5
perl-Time-HiRes-1.55-3
perl-HTML-Tagset-3.03-30
perl-libxml-enno-1.02-31
perl-Digest-SHA1-2.07-5
perl-SGMLSpm-1.03ii-14
perl-DBD-MySQL-2.9004-3.1
newt-perl-1.08-7
mod_perl-1.99_16-4
perl-HTML-Parser-3.35-6
perl-libxml-perl-0.07-30
perl-Digest-HMAC-1.01-13
perl-Filter-1.30-6
perl-DBI-1.40-8
perl-Parse-Yapp-1.05-32
perl-XML-Dumper-0.71-2
perl-Net-DNS-0.48-1
perl-DateManip-5.42a-3
perl-XML-Encoding-1.01-26
ImageMagick-perl-6.0.7.1-14
perl-XML-Parser-2.34-5

回答の条件
  • 1人2回まで
  • 登録:2008/08/29 09:51:33
  • 終了:2008/09/05 09:55:02

回答(2件)

id:b-wind No.1

b-wind回答回数3344ベストアンサー獲得回数4402008/08/29 12:38:09

ポイント60pt

/usr/local あたりにソースから取ってきてシステムが使う Perl とは完全に別にインストールするのがいいと思う。

可能ならカスタム rpm を自分で作れればベストだが。

RPM HOWTO: RPM パッケージの作成


依存関係を注意する必要はあるのでしょうか?

以下のコマンドで perl に依存しているパッケージが表示される。

rpm -q --whatrequires perl | sort | uniq

表示されるもの全ての依存関係を考えなければならないので、システム本体の Perl の入れ替えはお勧めできない。

id:youku555 No.2

youku555回答回数81ベストアンサー獲得回数02008/08/31 22:39:24

ポイント10pt

そのままインストールすれば、必要なメッセージが表示されると思いますが。

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません