php5.1から5.2にアップデートをしたのですが不具合が出て元に戻そうと下記の処置をしたのですがエラーがでて元に戻せなくなってしましました。


#rpmでphp周りをすべてアンインストール
rpm -e php-pear
rpm -e php-mcrypt
rpm -e php-mhash
rpm -e php-readline
rpm -e php-devel
rpm -e php

#yumでphpをインストール
yum install php

#エラーで失敗
Error: Missing Dependency: php-common = 5.1.6-3.el4s1.10 is needed by package php
Error: Missing Dependency: httpd-mmn = 20020903 is needed by package php
Error: Missing Dependency: php-cli = 5.1.6-3.el4s1.10 is needed by package php

回答の条件
  • URL必須
  • 1人5回まで
  • 登録:2008/12/15 14:21:47
  • 終了:2008/12/22 14:25:03

回答(1件)

id:tdoi No.1

tdoi回答回数174ベストアンサー獲得回数752008/12/16 00:41:07

ポイント60pt

どのように5.2へアップロードしようとしたのか分からないので、はずしているかもしれませんが、

ようは必要なパッケージが足りないといっているので、それをインストールしてあげればよいかと思います。

ためしに、

rpm -qa | grep php

とでもしてみて、php-commonやphp-cliがインストールされているか、あるいは、されていた場合はバージョンが要求を満たしているかを確認してみてください。

個々の依存関係を解消していってもよいですが、

yum install php php-common httpd-mmn php-cli

としたら解決するかもしれません。


何かの参考になれば。

http://dummy

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません