【Linux】【Perl】Mooseのインストールがうまくいきません。


Mooseというモジュールをcpanでインストールしようとしたのですがうまくいきません。
解決方法を教えてきただきたいです。

cpanは、http://fedorasrv.com/cpan2rpm.shtmlにしたがって
cpan2rpmを使っています。

++version++
OS:Fedora10(2.6.27.12-170.2.5.fc10.i686)
Perl:v5.10.0 built for i386-linux-thread-multi
cpan2rpm:2.028

++error log++
[root@licorice ~]# cpan2rpm --install Moose

-- cpan2rpm - Ver: 2.028 --
Upgrade check
Fetch: HTTP

-- module: Moose --
Using cached URL: http://search.cpan.org//CPAN/authors/id/D/DR/DROLSKY/Moose-0.72.tar.gz
Tarball found - not fetching
Metadata retrieval
Tarball extraction: [/root/rpmbuild/SOURCES/Moose-0.72.tar.gz]
Prototype mismatch: sub main::prompt: none vs ($;$) at (eval 43) line 2
main::BEGIN() called at (eval 43) line 2
eval {...} called at (eval 43) line 2
eval 'use ExtUtils::MakeMaker 6.48
;' called at /usr/bin/cpan2rpm line 485
main::get_meta() called at /usr/bin/cpan2rpm line 52
Unable to build module, the following dependencies have failed:
Class::MOP >= 0.77_01
Sub::Exporter >= 0.972
Stopped at /usr/bin/cpan2rpm line 490.
-- Done --

回答の条件
  • 1人50回まで
  • 登録:2009/02/28 15:13:48
  • 終了:2009/02/28 17:04:46

ベストアンサー

id:b-wind No.1

b-wind回答回数3344ベストアンサー獲得回数4402009/02/28 16:10:45

ポイント200pt

エラーメッセージのとおりです。

Class::MOP >= 0.77_01

Sub::Exporter >= 0.972

先に Class::MOP と Sub::Exporter の指定のバージョン以降をインストールしましょう。


CPAN モジュール自体はこのあたりの依存関係も解決してインストールできることが多いですが、

cpan2rpm コマンドでは自動では行ってくれません。

それぞれのモジュールをさかのぼって RPM 化していくしかないです。

id:upu

なるほど、わかりました。

さかのぼってインストールしていった結果

無事Mooseをインストールすることに成功しました。

ありがとうございます。

2009/02/28 17:03:39

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません