すみません、MovableType を バージョンアップしようとして、http://FQDN/mt/mt.cgi を

実行しましたら、下記エラーがでて先にすすみません。

Got an error: Can't locate object method "configure" via package "MT::ObjectDriverFactory" at lib/MT.pm line 1013.

すみませんが、解決のご教示いただけないでしょうか。解決時のポイントは私の通常のポイントで
お支払いします。よろしくお願いします。

回答の条件
  • URL必須
  • 1人2回まで
  • 登録:2009/08/03 10:40:28
  • 終了:2009/08/04 15:14:57

ベストアンサー

id:pahoo No.1

pahoo回答回数5960ベストアンサー獲得回数6332009/08/03 11:16:39

ポイント60pt

必要インストール環境、動作環境」に記されているDBやPerlモジュールが揃っているかどうか確認してください。


MTをバージョンを幾つから幾つにアップしたのか、サーバ環境は何なのか――これらの情報が無いので、これ以上は何とも言えません。

id:meichi

情報不足ですいません。環境は下記です。

OS:Solaris10

Movable Typeは 3.34から4.21 にバージョンアップしました。

perlは5.8.7がインストールされています。

DBはDBD-SQLite-1.08がインストールされています。

WebサーバはApache2.0.63です。

 

よろしくお願いします。

2009/08/03 11:34:13
  • id:pahoo
    > DBはDBD-SQLite-1.08がインストールされています。

    それは、Perlモジュール DBD::SQLite のことですよね。
    SQLite そのものはインストールされていますか?

    それから、回答に示したリンク先に挙がっている CPAN モジュールは揃っていますか?
  • id:meichi
    自力でなんとか、入り口まで たどりつきました。
    今回のポイントは、すいませんが 通常のお支払いでお願いします。
    よろしくお願いします。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません