現在VPSサーバの設定をWebminでいじっています。

Webminはたまにつかうものの常時起動しているとメモリーがもったいないのでxinetdを利用して必要なときだけ起動するようにしています。

今回学校からWebminにログインしようとしたところ、デフォルトの:10000では開くことができないことがわかりました。
通常のポート(80)ならばいけるはずなのですが、
http://blog.kenji00.com/2005/01/webmin80.html
を参考に変更してみてもうまくいきませんでした。

どなたか解決策をご存じの方はいらっしゃいませんでしょうか。

回答の条件
  • 1人2回まで
  • 13歳以上
  • 登録:2010/07/16 00:14:21
  • 終了:2010/07/23 00:15:03

ベストアンサー

id:matsubobo No.2

まつぼっくり回答回数18ベストアンサー獲得回数32010/07/17 10:33:48

ポイント35pt

トラブルシューティングでは、1つ1つ原因をつぶしていきましょう。

まず、サービスが正常に設定されているか確認してみましょう。

webminが動いているホストへリモートログインして、

% telnet localhost 10000

GET / HTTP1.0

などとして、レスポンスが帰ってくるか試してください。

正常に動いていれば、ネットワーク周りが問題。動いていなければサービスの問題に切り分けられます。

その他の回答(1件)

id:niwa-mikiho No.1

niwa-mikiho回答回数508ベストアンサー獲得回数382010/07/16 01:32:40

ポイント35pt

ルーターの 10000 番のポートを開ければ済む話では?

あと Webmin の設定で allow のとこに学校の IP アドレス (固定でなければ範囲指定) を追記。


これでいけるかと思います。

id:Grani

iptablesの設定は済ませています。今回はVPSを利用しているのでルーターをいじる必要はなくこれでいいはずだと認識しています。

また、現時点ではWebminは全てのIPアドレスからアクセスできるようにしているため関係ないと思っています。

書き忘れていましたが、http://blog.kenji00.com/2005/01/webmin80.htmlの方法では家からも入れませんでした。

2010/07/16 12:53:37
id:matsubobo No.2

まつぼっくり回答回数18ベストアンサー獲得回数32010/07/17 10:33:48ここでベストアンサー

ポイント35pt

トラブルシューティングでは、1つ1つ原因をつぶしていきましょう。

まず、サービスが正常に設定されているか確認してみましょう。

webminが動いているホストへリモートログインして、

% telnet localhost 10000

GET / HTTP1.0

などとして、レスポンスが帰ってくるか試してください。

正常に動いていれば、ネットワーク周りが問題。動いていなければサービスの問題に切り分けられます。

コメントはまだありません

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません