wordpress3.1について教えてください。

独自SSLを設定後にwordpress httpsプラグインをインストール後に有効化しようとしたら以下のエラーがでます。対処方法を教えてください。
Warning: parse_url() expects parameter 1 to be string, object given in /virtual/100.100.100.100/home/wp-content/plugins/wordpress-https/lib/WordPressHTTPS.php on line 200

回答の条件
  • 1人5回まで
  • 13歳以上
  • 登録:2012/10/09 12:44:00
  • 終了:2012/10/10 11:01:27

回答(3件)

id:papa-tomo No.1

パパトモ回答回数361ベストアンサー獲得回数1072012/10/09 13:30:07

ポイント50pt

パラメータのタイプが違うのが問題なので・・・

  • プラグインがターゲットとしているwordpressのバージョンと合っていない
  • プラグインのバグ
  • インストール方法に問題がある

などが思いつきます。

プラグインとwordpressのバージョンの組み合わせをチェックするのを勧めます。

id:kaji0245

ありがとうございます、バージョン等のチェックをしてみます<(_ _)>

2012/10/09 13:31:23
id:kaji0245

バージョンは合ってました(;^ω^)
wordpress3.0以上に対応となってました。

2012/10/09 13:35:45
id:sanada33 No.2

みかん回答回数293ベストアンサー獲得回数32012/10/09 19:41:37

違うタイプだとおもいます

id:oil999 No.3

oil999回答回数1728ベストアンサー獲得回数3202012/10/09 20:55:09

ポイント50pt

Proxyの設定をautoまたはonにしてみてください。

  • id:rouge_2008
    PHPのバージョンはいくつでしょうか?
    こちらはPHP5.2系、5.3系どちらの環境でも、3.1系のWordPressで特に問題なく有効化できました。
    もしバージョン5.1を使用しているのでしたら、5.3を利用してみてはいかがでしょうか?
    EC-CUBEの場合、php5.3のCGIタイプでは正常に動作しないという記載がありましたが、WordPressでは問題は発生しないかもしれませんので、一応どうなるか試してみてください。

    http://web.arena.ne.jp/suitex/support/manual/hp/script.html
    ----------------------------------------------------------------
    PHPバージョン5.3のCGIタイプについて

    PHPバージョン5.3をご利用になる際には、ご使用になる該当ディレクトリに .htaccess を設置しご利用下さい。
    ※.htaccessファイルの修正はFTPソフトで接続し、メモ帳などのテキストエディタ等で編集を行ないます。

    .htaccessに以下の項目を追記します。

    AddHandler application/x-httpd-php53 .php

    なお、既存のPHP(バージョン5.1)をご利用の際には上記を追加せずそのままご利用下さい。
    ----------------------------------------------------------------

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません