GDがインストール時にエラーとなってしまいます…


PHP Version 5.3.6でCentOS5を利用しております。
GDを使いたくYumでインストールを試したところ、既に最新版がインストールされています、となっているにも関わらず使うことができませんでした。

phpinfoでは「--without-gd」となっており、また

またインストール済みのパッケージには「gd 2.0.33-9.4.el5_4.2」がインストールされていました。
これを削除してから再インストールも試したのですが「yum remove php-gd」も「install failed!」でした…。

実際にGDが動くか下記のプログラムで動作を確認しましたが、画像は表示されなかったためGDをがやはり機能していないようです。

<?php
header("Content-type: image/png");
$im = @imagecreate(100, 50)
or die("Cannot Initialize new GD image stream");
$background_color = imagecolorallocate($im, 255, 255, 255);
$text_color = imagecolorallocate($im, 233, 14, 91);
imagestring($im, 1, 5, 5, "A Simple Text String", $text_color);
imagepng($im);
imagedestroy($im);
?>

インストール済みパッケージにGDがあるのに機能しないのが疑問な点で、一度すべてphpモジュールを削除し、再度インストールすれば解決する問題でしょうか?

どうぞよろしくお願い致します。

回答の条件
  • 1人5回まで
  • 13歳以上
  • 登録:2012/10/12 14:06:42
  • 終了:2012/10/19 14:10:03
id:ozakou

補足でエラー内容を記載致します。
よろしくお願い致します。

■実行したコマンド:
# yum -y install php-gd

■エラー全文:
Loaded plugins: downloadonly, fastestmirror
Loading mirror speeds from cached hostfile
* base: ftp.nara.wide.ad.jp
* epel: ftp.jaist.ac.jp
* extras: ftp.nara.wide.ad.jp
* updates: ftp.nara.wide.ad.jp
Setting up Install Process
Package yum-3.2.22-39.el5.centos.noarch already installed and latest version
No package install available.
Resolving Dependencies
--> Running transaction check
---> Package php-gd.x86_64 0:5.1.6-39.el5_8 set to be updated
--> Processing Dependency: php-common = 5.1.6-39.el5_8 for package: php-gd
--> Finished Dependency Resolution
php-gd-5.1.6-39.el5_8.x86_64 from updates has depsolving problems
--> Missing Dependency: php-common = 5.1.6-39.el5_8 is needed by package php-gd-5.1.6-39.el5_8.x86_64 (updates)
You could try using --skip-broken to work around the problem
You could try running: package-cleanup --problems
package-cleanup --dupes
rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
.. install failed!

回答(0件)

回答はまだありません

  • id:kokorohamoe
    You could try running: package-cleanup --problems
    と書いてありますが トライしてもダメでしたか?
    パッケージの依存関係が壊れていると出ていますので
    yum update
    などはされていますか?

この質問への反応(ブックマークコメント)

トラックバック

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません