WindowsXPについてです。

最近、LAN接続のNAS内にあるソフトを実行すると、「発行元を確認できませんでした。このソフトウェアを実行しますか?」と警告が出るようになりました。(その前までは普通に起動できてました)
Windowsの更新はしたような気がしますが、その他に弄った覚えはありません。

いろいろと検索して試した結果、

「この種類のファイルであれば常に警告する」のチェックをはずす

チェック自体がない

インターネットオプションの「次の Web サイトをゾーンに追加する」にIPアドレスを追加

変わらず

ショートカットなどをUNC名(\\server\○○\...)で指定

変わらず

ファイヤーウォール設定の例外にプログラムを追加

変わらず

"SaveZoneInformation"=dword:00000001のレジストリキーを追加

変わらず

という結果です。
環境はWindowsXP Home SP2で、NASはTS-0.3TGL/R5です。
警告が出るソフトはいろいろですが、例えばばFFFTPなどに加え、.js(JavaScript)ファイルなども警告が出ます。
他の解決方法、また原因がわかる方はいますか?

回答の条件
  • 1人3回まで
  • 登録:2008/04/16 10:13:13
  • 終了:2008/04/16 16:26:38

回答(2件)

id:pahoo No.1

pahoo回答回数5960ベストアンサー獲得回数6332008/04/16 11:58:37

ポイント50pt

インターネットから入手したファイルの実行時にXP SP2で警告が出る仕組みは?」を参考にしてゾーン情報を変更してみてください。


ただ、個人的に、この方法はお勧めできません。

ネット上の実行形式ファイルは、ウイルス検査をパスしているとは限りません(。ダウンロードして、随時ウイルス検査している状態で実行する方が安全です。

id:indiana

ありがとうございます。

リンク先の、さらにリンク先(Microsoftのページ)が存在しないため、詳しく設定できませんでした。

また、ソフトの実行ファイルのプロパティ・ウインドウにも[ブロックの解除]ボタンがないため、設定できませんでした。

2008/04/16 14:44:21
id:ken33jp No.2

ken33jp回答回数928ベストアンサー獲得回数132008/04/16 13:33:16

ポイント20pt

警告出るのは普通なのですが、

何か支障がありますか?

id:indiana

よく使用するソフトなので、毎回警告が出るのは非常にわずらわしいです。

「警告出るのは普通」とのことですが、少し前までは警告が出ていませんでした。

警告が出ないのが「普通じゃない」ということでしょうか・・・。

2008/04/16 14:46:04
  • id:cgo01
    # XP Pro SP2 & IE 7 で試したので 多少文言等 違うかもしれませんが、

    NAS Server への アクセスを ホスト名 ( NAS-SERVER ) だと仮定して

    inetcpl.cpl ( インターネットのプロパティ )の
    「セキュリティ」タブを選択する。
    「信頼済みサイト」を選択し、「サイト(S)」ボタンを押す。
    ダイアログのテキストボックスに
    file://NAS-SERVER
    と入力して、「追加(A)」ボタンを押す。「閉じる(C)」ボタンを押して
    ダイアログを閉じる。

    セキュリティのレベルに関して、
    「レベルのカスタマイズ(C)」を押して、ダイアログを表示。
    「その他」のサブ項目
    「アプリケーションと安全でないファイルの起動」
    が 「有効にする」になっていることを確認する
    ( なっていなければ それを選ぶ )
  • id:indiana
    >cgo01さん
    ありがとうございます。cgo01さんの方法で解決しました。

    実際は「信頼済みサイト」に「file://NAS-SERVER」入力すると、「このゾーンに追加したサイトには、https:// prefix を使用する必要があります。この prefix は、セキュリティで保護された接続を保証します。」と警告が出て追加できませんでした。

    しかし「レベルのカスタマイズ(C)」で「アプリケーションと安全でないファイルの起動」を「有効にする」と大丈夫でした。
    回等へ書き込んでいただければポイントを差し上げられたんですが・・・残念です・・・
  • id:cgo01
    > と警告が出て追加できませんでした。

    多分、
    「このゾーンのサイトにはすべてサーバーの確認(https:) を必要とする(S)」
    にチェックが入っているから。
    それをはずしておけば、追加できると思います。
  • id:Sopp2dash
    IE7の場合
    1.IE7を立ち上げ、『ツール』の『インターネットオプション』を選択
    2.『セキュリティ』タブを押し、『ローカルイントラネット』を選ぶ
    3.『サイト』ボタンを押し、『イントラネットのネットワークを自動的に検出する』のチェックボックスを外す
    4.『OK』ボタンを押す

    IE6の場合
    4.詳細設定
    5.次のWEBサイトをゾーンに追加する で実行ファイルのあるサーバーのアドレスを入力する

    という方法もあるようです。参考まで
  • id:indiana
    >cgo01さん
    なるほど、試してみたらできました。
    Windowsの警告文というのは本当にわかりにくいですね・・・。

    >Sopp2dashさん
    IE7と6で設定方法が違うんですね。
    もしまたこの症状が出たら参考にさせていただきます。
    今回の質問の類を検索していると、他にも同じ症状が出てしまう方がけっこういるようですね。

この質問への反応(ブックマークコメント)

「あの人に答えてほしい」「この質問はあの人が答えられそう」というときに、回答リクエストを送ってみてましょう。

これ以上回答リクエストを送信することはできません。制限について

絞り込み :
はてなココの「ともだち」を表示します。
回答リクエストを送信したユーザーはいません